1
1
mirror of https://github.com/OpenVoiceOS/OpenVoiceOS synced 2025-01-13 01:33:45 +01:00
OpenVoiceOS/buildroot-external/package/kaldi/0001-Fix-cmake-install-rpath.patch
j1nx 08e08a0c5b [WIP] Build vosk-api andits dependencies from source
This so we can use the same package for any architecture in the future.
2022-12-20 15:58:35 +01:00

26 lines
696 B
Diff

From 8651f18563ae11be6f26edc35afce32e884b2ed5 Mon Sep 17 00:00:00 2001
From: j1nx <p.steenbergen@j1nx.nl>
Date: Mon, 19 Dec 2022 10:20:48 +0100
Subject: [PATCH 1/1] Fix cmake install rpath
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0ca3ea28..b7aa22fa9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,7 +52,7 @@ if(BUILD_SHARED_LIBS)
elseif(APPLE)
set(CMAKE_INSTALL_RPATH "@loader_path")
else()
- set(CMAKE_INSTALL_RPATH "$ORIGIN;$ORIGIN/../lib;$ORIGIN/../../tools/openfst/lib")
+ set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR})
endif()
endif()
--
2.34.1