1
1
mirror of https://github.com/OpenVoiceOS/OpenVoiceOS synced 2025-02-06 05:23:37 +01:00
OpenVoiceOS/buildroot-patches/0114-Just-build-all-qttools.patch

116 lines
4.2 KiB
Diff

From 38eb7557c88fed444774792af1ab30249c862d97 Mon Sep 17 00:00:00 2001
From: j1nx <p.steenbergen@j1nx.nl>
Date: Wed, 11 Nov 2020 14:41:06 +0100
Subject: [PATCH 1/1] Just build all qttools
---
...-designer-tool-fixes-configure-error.patch | 46 -------------------
package/qt5/qt5tools/qt5tools.mk | 28 -----------
2 files changed, 74 deletions(-)
delete mode 100644 package/qt5/qt5tools/0001-Disable-designer-tool-fixes-configure-error.patch
diff --git a/package/qt5/qt5tools/0001-Disable-designer-tool-fixes-configure-error.patch b/package/qt5/qt5tools/0001-Disable-designer-tool-fixes-configure-error.patch
deleted file mode 100644
index 20c5e2a470..0000000000
--- a/package/qt5/qt5tools/0001-Disable-designer-tool-fixes-configure-error.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From a70da8d731b969305096a0213b70659dc641591a Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Tue, 17 Dec 2019 11:01:59 +0100
-Subject: [PATCH] Disable designer tool (fixes configure error).
-
-Fixes:
-
- .../build/qt5tools-5.14.0/src/designer/src/components/lib/lib.pro
- Project ERROR: Multiple modules claim plugin type 'designer' (uitools, in addition to designer)
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
-[Rebased for Qt5.15.0]
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- src/linguist/linguist/linguist.pro | 2 +-
- src/src.pro | 3 ---
- 2 files changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/src/linguist/linguist/linguist.pro b/src/linguist/linguist/linguist.pro
-index d083896..7d74cfc 100644
---- a/src/linguist/linguist/linguist.pro
-+++ b/src/linguist/linguist/linguist.pro
-@@ -1,4 +1,4 @@
--QT += core-private gui-private widgets uitools-private printsupport
-+QT += core-private gui-private widgets printsupport
-
- DEFINES += QT_NO_CAST_FROM_ASCII QT_NO_CAST_TO_ASCII
-
-diff --git a/src/src.pro b/src/src.pro
-index 5c256ea..6d079be 100644
---- a/src/src.pro
-+++ b/src/src.pro
-@@ -7,10 +7,7 @@ qtHaveModule(widgets) {
- QT_FOR_CONFIG += widgets
- qtConfig(pushbutton):qtConfig(toolbutton) {
- SUBDIRS = assistant \
-- designer \
- pixeltool
--
-- linguist.depends = designer
- }
- qtHaveModule(quick):qtConfig(thread):qtConfig(toolbutton): SUBDIRS += distancefieldgenerator
- }
---
-2.26.2
-
diff --git a/package/qt5/qt5tools/qt5tools.mk b/package/qt5/qt5tools/qt5tools.mk
index 0543afd8f7..1d07261474 100644
--- a/package/qt5/qt5tools/qt5tools.mk
+++ b/package/qt5/qt5tools/qt5tools.mk
@@ -21,44 +21,16 @@ endif
QT5TOOLS_LICENSE = GPL-2.0+ or LGPL-3.0, GPL-3.0 with exception(tools), GFDL-1.3 (docs)
QT5TOOLS_LICENSE_FILES = LICENSE.GPL2 LICENSE.GPL3 LICENSE.GPL3-EXCEPT LICENSE.LGPL3 LICENSE.FDL
-QT5TOOLS_BUILD_DIRS_$(BR2_PACKAGE_QT5TOOLS_LINGUIST_TOOLS) += \
- linguist/lconvert linguist/lrelease linguist/lupdate
-QT5TOOLS_INSTALL_STAGING_DIR_$(BR2_PACKAGE_QT5TOOLS_LINGUIST_TOOLS) += \
- linguist
-
ifeq ($(BR2_PACKAGE_QT5TOOLS_QDOC_TOOL),y)
-QT5TOOLS_BUILD_DIRS_y += qdoc
-QT5TOOLS_INSTALL_STAGING_DIR_y += qdoc
QT5TOOLS_DEPENDENCIES += host-clang
endif
-QT5TOOLS_BUILD_DIRS_$(BR2_PACKAGE_QT5TOOLS_PIXELTOOL) += pixeltool
QT5TOOLS_INSTALL_TARGET_$(BR2_PACKAGE_QT5TOOLS_PIXELTOOL) += pixeltool
-QT5TOOLS_BUILD_DIRS_$(BR2_PACKAGE_QT5TOOLS_QTDIAG) += qtdiag
QT5TOOLS_INSTALL_TARGET_$(BR2_PACKAGE_QT5TOOLS_QTDIAG) += qtdiag
-QT5TOOLS_BUILD_DIRS_$(BR2_PACKAGE_QT5TOOLS_QTPATHS) += qtpaths
QT5TOOLS_INSTALL_TARGET_$(BR2_PACKAGE_QT5TOOLS_QTPATHS) += qtpaths
-QT5TOOLS_BUILD_DIRS_$(BR2_PACKAGE_QT5TOOLS_QTPLUGININFO) += qtplugininfo
QT5TOOLS_INSTALL_TARGET_$(BR2_PACKAGE_QT5TOOLS_QTPLUGININFO) += qtplugininfo
-define QT5TOOLS_BUILD_CMDS
- $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) sub-src-qmake_all
- $(foreach p,$(QT5TOOLS_BUILD_DIRS_y), \
- $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src/$(p)$(sep))
-endef
-
-# use install target to copy cmake module files
-define QT5TOOLS_INSTALL_STAGING_CMDS
- $(foreach p,$(QT5TOOLS_INSTALL_STAGING_DIR_y), \
- $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src/$(p) install$(sep))
-endef
-
-define QT5TOOLS_INSTALL_TARGET_CMDS
- $(foreach p,$(QT5TOOLS_INSTALL_TARGET_y), \
- $(INSTALL) -D -m0755 $(@D)/bin/$(p) $(TARGET_DIR)/usr/bin/$(p)$(sep))
-endef
-
$(eval $(qmake-package))
--
2.20.1