mirror of
https://github.com/OpenVoiceOS/OpenVoiceOS
synced 2024-12-26 16:53:47 +01:00
50 lines
1.4 KiB
Diff
50 lines
1.4 KiB
Diff
From 509d23d8abadba2561aec14998607fd9df45a512 Mon Sep 17 00:00:00 2001
|
|
From: j1nx <p.steenbergen@j1nx.nl>
|
|
Date: Fri, 18 Jun 2021 21:13:52 +0200
|
|
Subject: [PATCH 1/1] Simplify setup
|
|
|
|
---
|
|
setup.py | 15 ---------------
|
|
1 file changed, 15 deletions(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 36853d0..a9ae9b4 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -18,26 +18,12 @@ __author__ = 'seanfitz'
|
|
import os
|
|
from setuptools import setup
|
|
|
|
-with open("README.md", "r") as fh:
|
|
- long_description = fh.read()
|
|
-
|
|
-
|
|
-def required(requirements_file):
|
|
- """Read requirements file and remove comments and empty lines."""
|
|
- base_dir = os.path.abspath(os.path.dirname(__file__))
|
|
- with open(os.path.join(base_dir, requirements_file), 'r') as f:
|
|
- requirements = f.read().splitlines()
|
|
- return [pkg for pkg in requirements
|
|
- if pkg.strip() and not pkg.startswith("#")]
|
|
-
|
|
setup(
|
|
name="adapt-parser",
|
|
version="0.4.1",
|
|
author="Sean Fitzgerald",
|
|
author_email="sean@fitzgeralds.me",
|
|
description=("A text-to-intent parsing framework."),
|
|
- long_description=long_description,
|
|
- long_description_content_type="text/markdown",
|
|
license=("Apache License 2.0"),
|
|
keywords="natural language processing",
|
|
url="https://github.com/MycroftAI/adapt",
|
|
@@ -55,5 +41,4 @@ setup(
|
|
'Programming Language :: Python :: 3.9',
|
|
],
|
|
|
|
- install_requires=required('requirements.txt')
|
|
)
|
|
--
|
|
2.20.1
|
|
|