1
1
mirror of https://github.com/OpenVoiceOS/OpenVoiceOS synced 2024-12-21 13:54:05 +01:00
OpenVoiceOS/buildroot-patches/0005-Downgrade-dbus-python-back-to-Python3.7-compatible-v.patch
2019-12-15 20:03:40 +01:00

86 lines
3.5 KiB
Diff

From 287a3b1a8c05ac091870b2b3b305d12b584f6531 Mon Sep 17 00:00:00 2001
From: Peter Steenbergen <info@j1nx.nl>
Date: Sun, 15 Dec 2019 10:45:06 +0100
Subject: [PATCH 1/1] Downgrade dbus-python back to Python3.7 compatible
version.
---
package/dbus-python/Config.in | 2 +-
package/dbus-python/dbus-python.hash | 3 +--
package/dbus-python/dbus-python.mk | 19 ++++++++++---------
3 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/package/dbus-python/Config.in b/package/dbus-python/Config.in
index 4bfb59ed91..332726348d 100644
--- a/package/dbus-python/Config.in
+++ b/package/dbus-python/Config.in
@@ -4,7 +4,7 @@ config BR2_PACKAGE_DBUS_PYTHON
depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
depends on BR2_PACKAGE_DBUS
depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
- select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_DBUS_GLIB
# pyexpat: runtime dependency only
select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON
select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3
diff --git a/package/dbus-python/dbus-python.hash b/package/dbus-python/dbus-python.hash
index 58b0a75908..5bf2f507c6 100644
--- a/package/dbus-python/dbus-python.hash
+++ b/package/dbus-python/dbus-python.hash
@@ -1,6 +1,5 @@
# Locally calculated after checking pgp signature
-sha256 cdd4de2c4f5e58f287b12013ed7b41dee81d503c8d0d2397c5bd2fb01badf260 dbus-python-1.2.12.tar.gz
+sha256 abf12bbb765e300bf8e2a1b2f32f85949eab06998dbda127952c31cb63957b6f dbus-python-1.2.8.tar.gz
# Locally calculated
sha256 1e4562245383fdb5203b1769789e5b28bba21af4923aea7e8b2614f7f93623c0 COPYING
-sha256 064523e3ab64d6f03904132b2cc4a1bd8500586edb4cd050c2ff2b96aed4c33b dbus-gmain/COPYING
diff --git a/package/dbus-python/dbus-python.mk b/package/dbus-python/dbus-python.mk
index cf4882d8ee..eaf4e5f483 100644
--- a/package/dbus-python/dbus-python.mk
+++ b/package/dbus-python/dbus-python.mk
@@ -4,13 +4,16 @@
#
################################################################################
-DBUS_PYTHON_VERSION = 1.2.12
+DBUS_PYTHON_VERSION = 1.2.8
DBUS_PYTHON_SITE = http://dbus.freedesktop.org/releases/dbus-python
DBUS_PYTHON_INSTALL_STAGING = YES
-DBUS_PYTHON_LICENSE = MIT (dbus-python), AFL-2.1 or GPL-2.0+ (dbus-gmain)
-DBUS_PYTHON_LICENSE_FILES = COPYING dbus-gmain/COPYING
-DBUS_PYTHON_DEPENDENCIES = dbus libglib2
-HOST_DBUS_PYTHON_DEPENDENCIES = host-dbus host-libglib2
+DBUS_PYTHON_LICENSE = MIT
+DBUS_PYTHON_LICENSE_FILES = COPYING
+DBUS_PYTHON_DEPENDENCIES = dbus-glib
+DBUS_PYTHON_CONF_OPTS = --disable-html-docs --disable-api-docs
+
+HOST_DBUS_PYTHON_DEPENDENCIES = host-dbus-glib
+HOST_DBUS_PYTHON_CONF_OPTS = --disable-html-docs --disable-api-docs
ifeq ($(BR2_PACKAGE_PYTHON),y)
DBUS_PYTHON_DEPENDENCIES += python host-python
@@ -32,16 +35,14 @@ DBUS_PYTHON_DEPENDENCIES += python3 host-python3
DBUS_PYTHON_CONF_ENV += \
PYTHON=$(HOST_DIR)/bin/python3 \
PYTHON_INCLUDES="`$(STAGING_DIR)/usr/bin/python3-config --includes`" \
- PYTHON_LIBS="`$(STAGING_DIR)/usr/bin/python3-config --ldflags`" \
- PYTHON_EXTRA_LIBS="`$(STAGING_DIR)/usr/bin/python3-config --libs --embed`"
+ PYTHON_LIBS="`$(STAGING_DIR)/usr/bin/python3-config --ldflags`"
HOST_DBUS_PYTHON_DEPENDENCIES += host-python3
HOST_DBUS_PYTHON_CONF_ENV += \
PYTHON=$(HOST_DIR)/bin/python3 \
PYTHON_INCLUDES="`$(HOST_DIR)/usr/bin/python3-config --includes`" \
- PYTHON_LIBS="`$(HOST_DIR)/usr/bin/python3-config --ldflags`" \
- PYTHON_EXTRA_LIBS="`$(HOST_DIR)/usr/bin/python3-config --libs --embed`"
+ PYTHON_LIBS="`$(HOST_DIR)/usr/bin/python3-config --ldflags`"
endif
$(eval $(autotools-package))
--
2.24.0.rc1