108 lines
4.5 KiB
Diff
108 lines
4.5 KiB
Diff
From 558f6ce4014280563a57eecd446969034ab36d77 Mon Sep 17 00:00:00 2001
|
|
From: Peter Steenbergen <info@j1nx.nl>
|
|
Date: Mon, 7 Jan 2019 16:36:09 +0100
|
|
Subject: [PATCH 1/1] Downgrade python-tornado to 4.5.3
|
|
|
|
---
|
|
.../python-tornado/0001-Disable-SSL-checks.patch | 45 ----------------------
|
|
package/python-tornado/Config.in | 2 -
|
|
package/python-tornado/python-tornado.hash | 1 +
|
|
package/python-tornado/python-tornado.mk | 4 +-
|
|
4 files changed, 3 insertions(+), 49 deletions(-)
|
|
delete mode 100644 package/python-tornado/0001-Disable-SSL-checks.patch
|
|
|
|
diff --git a/package/python-tornado/0001-Disable-SSL-checks.patch b/package/python-tornado/0001-Disable-SSL-checks.patch
|
|
deleted file mode 100644
|
|
index 272afd64fe..0000000000
|
|
--- a/package/python-tornado/0001-Disable-SSL-checks.patch
|
|
+++ /dev/null
|
|
@@ -1,45 +0,0 @@
|
|
-From 82a3bbc2ac41b5a1b34a53f97459558efe131f14 Mon Sep 17 00:00:00 2001
|
|
-From: Jan Dohl <polygon@wh2.tu-dresden.de>
|
|
-Date: Sun, 24 Jun 2018 16:00:54 +0200
|
|
-Subject: [PATCH] Disable SSL checks
|
|
-
|
|
-Checking for SSL support in the Python used on the build system is not
|
|
-relevant, as we need SSL support in the Python on the target system.
|
|
-
|
|
-Signed-off-by: Jan Dohl <polygon@wh2.tu-dresden.de>
|
|
----
|
|
- setup.py | 11 -----------
|
|
- 1 file changed, 11 deletions(-)
|
|
-
|
|
-diff --git a/setup.py b/setup.py
|
|
-index 6fbb10a8..1a9220c7 100644
|
|
---- a/setup.py
|
|
-+++ b/setup.py
|
|
-@@ -15,7 +15,6 @@
|
|
-
|
|
- import os
|
|
- import platform
|
|
--import ssl
|
|
- import sys
|
|
- import warnings
|
|
-
|
|
-@@ -137,16 +136,6 @@ if setuptools is not None:
|
|
- python_requires = '>= 2.7, !=3.0.*, !=3.1.*, !=3.2.*, != 3.3.*'
|
|
- kwargs['python_requires'] = python_requires
|
|
-
|
|
--# Verify that the SSL module has all the modern upgrades. Check for several
|
|
--# names individually since they were introduced at different versions,
|
|
--# although they should all be present by Python 3.4 or 2.7.9.
|
|
--if (not hasattr(ssl, 'SSLContext') or
|
|
-- not hasattr(ssl, 'create_default_context') or
|
|
-- not hasattr(ssl, 'match_hostname')):
|
|
-- raise ImportError("Tornado requires an up-to-date SSL module. This means "
|
|
-- "Python 2.7.9+ or 3.4+ (although some distributions have "
|
|
-- "backported the necessary changes to older versions).")
|
|
--
|
|
- setup(
|
|
- name="tornado",
|
|
- version=version,
|
|
---
|
|
-2.14.4
|
|
-
|
|
diff --git a/package/python-tornado/Config.in b/package/python-tornado/Config.in
|
|
index 1afbdc5729..a0ee78fb7a 100644
|
|
--- a/package/python-tornado/Config.in
|
|
+++ b/package/python-tornado/Config.in
|
|
@@ -2,8 +2,6 @@ config BR2_PACKAGE_PYTHON_TORNADO
|
|
bool "python-tornado"
|
|
select BR2_PACKAGE_PYTHON_ZLIB if BR2_PACKAGE_PYTHON
|
|
select BR2_PACKAGE_PYTHON3_ZLIB if BR2_PACKAGE_PYTHON3
|
|
- select BR2_PACKAGE_PYTHON_SSL if BR2_PACKAGE_PYTHON
|
|
- select BR2_PACKAGE_PYTHON3_SSL if BR2_PACKAGE_PYTHON3
|
|
select BR2_PACKAGE_PYTHON_SINGLEDISPATCH if BR2_PACKAGE_PYTHON # runtime
|
|
select BR2_PACKAGE_PYTHON_BACKPORTS_ABC if BR2_PACKAGE_PYTHON # runtime
|
|
select BR2_PACKAGE_PYTHON_CERTIFI if BR2_PACKAGE_PYTHON # runtime
|
|
diff --git a/package/python-tornado/python-tornado.hash b/package/python-tornado/python-tornado.hash
|
|
index fbf5efa60a..7cfaefad73 100644
|
|
--- a/package/python-tornado/python-tornado.hash
|
|
+++ b/package/python-tornado/python-tornado.hash
|
|
@@ -1,5 +1,6 @@
|
|
# md5, sha256 from https://pypi.org/pypi/tornado/json
|
|
md5 a1ce4f392d30ff0ebcb255150d89b826 tornado-5.1.1.tar.gz
|
|
sha256 4e5158d97583502a7e2739951553cbd88a72076f152b4b11b64b9a10c4c49409 tornado-5.1.1.tar.gz
|
|
+sha256 6d14e47eab0e15799cf3cdcc86b0b98279da68522caace2bd7ce644287685f0a tornado-4.5.3.tar.gz
|
|
# Locally computed sha256 checksums
|
|
sha256 cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30 LICENSE
|
|
diff --git a/package/python-tornado/python-tornado.mk b/package/python-tornado/python-tornado.mk
|
|
index 71f536f023..b86e476fd6 100644
|
|
--- a/package/python-tornado/python-tornado.mk
|
|
+++ b/package/python-tornado/python-tornado.mk
|
|
@@ -4,9 +4,9 @@
|
|
#
|
|
################################################################################
|
|
|
|
-PYTHON_TORNADO_VERSION = 5.1.1
|
|
+PYTHON_TORNADO_VERSION = 4.5.3
|
|
PYTHON_TORNADO_SOURCE = tornado-$(PYTHON_TORNADO_VERSION).tar.gz
|
|
-PYTHON_TORNADO_SITE = https://files.pythonhosted.org/packages/e6/78/6e7b5af12c12bdf38ca9bfe863fcaf53dc10430a312d0324e76c1e5ca426
|
|
+PYTHON_TORNADO_SITE = https://files.pythonhosted.org/packages/e3/7b/e29ab3d51c8df66922fea216e2bddfcb6430fb29620e5165b16a216e0d3c
|
|
PYTHON_TORNADO_LICENSE = Apache-2.0
|
|
PYTHON_TORNADO_LICENSE_FILES = LICENSE
|
|
PYTHON_TORNADO_SETUP_TYPE = setuptools
|
|
--
|
|
2.11.0
|
|
|