OpenVoiceOS/buildroot-patches/0010-Downgrade-python-torna...

112 lines
4.7 KiB
Diff

From 6da3d4e89056a749613da580f0f32e2bc5e69f2d Mon Sep 17 00:00:00 2001
From: Peter Steenbergen <info@j1nx.nl>
Date: Mon, 29 Oct 2018 15:36:21 +0100
Subject: [PATCH 1/1] Downgrade python-tornado to 4.2.1
---
.../python-tornado/0001-Disable-SSL-checks.patch | 45 ----------------------
package/python-tornado/Config.in | 2 -
package/python-tornado/python-tornado.hash | 7 ++--
package/python-tornado/python-tornado.mk | 6 +--
4 files changed, 7 insertions(+), 53 deletions(-)
delete mode 100644 package/python-tornado/0001-Disable-SSL-checks.patch
diff --git a/package/python-tornado/0001-Disable-SSL-checks.patch b/package/python-tornado/0001-Disable-SSL-checks.patch
deleted file mode 100644
index 272afd64fe..0000000000
--- a/package/python-tornado/0001-Disable-SSL-checks.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 82a3bbc2ac41b5a1b34a53f97459558efe131f14 Mon Sep 17 00:00:00 2001
-From: Jan Dohl <polygon@wh2.tu-dresden.de>
-Date: Sun, 24 Jun 2018 16:00:54 +0200
-Subject: [PATCH] Disable SSL checks
-
-Checking for SSL support in the Python used on the build system is not
-relevant, as we need SSL support in the Python on the target system.
-
-Signed-off-by: Jan Dohl <polygon@wh2.tu-dresden.de>
----
- setup.py | 11 -----------
- 1 file changed, 11 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 6fbb10a8..1a9220c7 100644
---- a/setup.py
-+++ b/setup.py
-@@ -15,7 +15,6 @@
-
- import os
- import platform
--import ssl
- import sys
- import warnings
-
-@@ -137,16 +136,6 @@ if setuptools is not None:
- python_requires = '>= 2.7, !=3.0.*, !=3.1.*, !=3.2.*, != 3.3.*'
- kwargs['python_requires'] = python_requires
-
--# Verify that the SSL module has all the modern upgrades. Check for several
--# names individually since they were introduced at different versions,
--# although they should all be present by Python 3.4 or 2.7.9.
--if (not hasattr(ssl, 'SSLContext') or
-- not hasattr(ssl, 'create_default_context') or
-- not hasattr(ssl, 'match_hostname')):
-- raise ImportError("Tornado requires an up-to-date SSL module. This means "
-- "Python 2.7.9+ or 3.4+ (although some distributions have "
-- "backported the necessary changes to older versions).")
--
- setup(
- name="tornado",
- version=version,
---
-2.14.4
-
diff --git a/package/python-tornado/Config.in b/package/python-tornado/Config.in
index 1afbdc5729..a0ee78fb7a 100644
--- a/package/python-tornado/Config.in
+++ b/package/python-tornado/Config.in
@@ -2,8 +2,6 @@ config BR2_PACKAGE_PYTHON_TORNADO
bool "python-tornado"
select BR2_PACKAGE_PYTHON_ZLIB if BR2_PACKAGE_PYTHON
select BR2_PACKAGE_PYTHON3_ZLIB if BR2_PACKAGE_PYTHON3
- select BR2_PACKAGE_PYTHON_SSL if BR2_PACKAGE_PYTHON
- select BR2_PACKAGE_PYTHON3_SSL if BR2_PACKAGE_PYTHON3
select BR2_PACKAGE_PYTHON_SINGLEDISPATCH if BR2_PACKAGE_PYTHON # runtime
select BR2_PACKAGE_PYTHON_BACKPORTS_ABC if BR2_PACKAGE_PYTHON # runtime
select BR2_PACKAGE_PYTHON_CERTIFI if BR2_PACKAGE_PYTHON # runtime
diff --git a/package/python-tornado/python-tornado.hash b/package/python-tornado/python-tornado.hash
index c64e537eed..4fc7ad45a3 100644
--- a/package/python-tornado/python-tornado.hash
+++ b/package/python-tornado/python-tornado.hash
@@ -1,3 +1,4 @@
-# md5, sha256 from https://pypi.python.org/pypi/tornado/json
-md5 e5e24ce1c8a4e6442dc38d470172f59e tornado-5.0.2.tar.gz
-sha256 1b83d5c10550f2653380b4c77331d6f8850f287c4f67d7ce1e1c639d9222fbc7 tornado-5.0.2.tar.gz
+# md5 from https://pypi.python.org/pypi/tornado/json, sha256 locally computed
+md5 838687d20923360af5ab59f101e9e02e tornado-4.5.1.tar.gz
+sha256 db0904a28253cfe53e7dedc765c71596f3c53bb8a866ae50123320ec1a7b73fd tornado-4.5.1.tar.gz
+sha256 a16fcdc4f76b184cb82f4f9eaeeacef6113b524b26a2cb331222e4a7fa6f2969 tornado-4.2.1.tar.gz
diff --git a/package/python-tornado/python-tornado.mk b/package/python-tornado/python-tornado.mk
index ed3a61fcf8..d04190d046 100644
--- a/package/python-tornado/python-tornado.mk
+++ b/package/python-tornado/python-tornado.mk
@@ -4,11 +4,11 @@
#
################################################################################
-PYTHON_TORNADO_VERSION = 5.0.2
+PYTHON_TORNADO_VERSION = 4.2.1
PYTHON_TORNADO_SOURCE = tornado-$(PYTHON_TORNADO_VERSION).tar.gz
-PYTHON_TORNADO_SITE = https://pypi.python.org/packages/cf/d1/3be271ae5eba9fb59df63c9891fdc7d8044b999e8ac145994cdbfd2ae66a
+PYTHON_TORNADO_SITE = https://files.pythonhosted.org/packages/ec/af/c40ad78dacdef134f3e08b3103c3c859b14ceb9639d344811339227b6444
PYTHON_TORNADO_LICENSE = Apache-2.0
-PYTHON_TORNADO_LICENSE_FILES = LICENSE
PYTHON_TORNADO_SETUP_TYPE = setuptools
$(eval $(python-package))
+$(eval $(host-python-package))
--
2.11.0