26 lines
720 B
Diff
26 lines
720 B
Diff
From 79bfc57404cd8d42236283b44f956209ff486e21 Mon Sep 17 00:00:00 2001
|
|
From: Peter Steenbergen <info@j1nx.nl>
|
|
Date: Sun, 8 Dec 2019 12:54:33 +0100
|
|
Subject: [PATCH 1/1] Only install typing if Python version < 3.5
|
|
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 5e3167a..18eb0fc 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -26,7 +26,7 @@ setup(
|
|
version='0.8.3',
|
|
packages=['msm'],
|
|
install_requires=[
|
|
- 'GitPython', 'typing', 'fasteners', 'pyyaml', 'pako',
|
|
+ 'GitPython', 'typing;python_version<"3.5"', 'fasteners', 'pyyaml', 'pako',
|
|
'lazy'
|
|
],
|
|
url='https://github.com/MycroftAI/mycroft-skills-manager',
|
|
--
|
|
2.24.0.rc1
|
|
|