mirror of
https://github.com/OpenVoiceOS/OpenVoiceOS
synced 2024-12-26 16:53:47 +01:00
50 lines
1.7 KiB
Diff
50 lines
1.7 KiB
Diff
From 081c2e4e3cf021efb2853a485a18b563e88f6117 Mon Sep 17 00:00:00 2001
|
|
From: Terry Heo <terryheo@google.com>
|
|
Date: Tue, 1 Nov 2022 15:55:30 -0700
|
|
Subject: [PATCH] lite: Update CMakeLists.txt
|
|
|
|
This changes are needed to build kernel tests.
|
|
|
|
PiperOrigin-RevId: 485439972
|
|
|
|
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
|
[james.hilliard1@gmail.com: backport from upstream commit
|
|
081c2e4e3cf021efb2853a485a18b563e88f6117]
|
|
---
|
|
tensorflow/lite/CMakeLists.txt | 7 ++++++-
|
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/tensorflow/lite/CMakeLists.txt b/tensorflow/lite/CMakeLists.txt
|
|
index 9dfbb4b72f3..fd8b3faf1e2 100644
|
|
--- a/tensorflow/lite/CMakeLists.txt
|
|
+++ b/tensorflow/lite/CMakeLists.txt
|
|
@@ -209,6 +209,9 @@ list(FILTER TFLITE_SRCS EXCLUDE REGEX ".*tflite_with_xnnpack\\.cc$")
|
|
# Exclude Flex related files.
|
|
list(FILTER TFLITE_SRCS EXCLUDE REGEX ".*with_selected_ops\\.cc$")
|
|
|
|
+# Exclude tensorflow_profiler_logger files.
|
|
+list(FILTER TFLITE_SRCS EXCLUDE REGEX ".*tensorflow_profiler_logger\\.cc$")
|
|
+
|
|
if(_TFLITE_ENABLE_MMAP)
|
|
list(FILTER TFLITE_SRCS EXCLUDE REGEX ".*mmap_allocation_disabled\\.cc$")
|
|
else()
|
|
@@ -222,6 +225,7 @@ if(NOT "${CMAKE_SYSTEM_NAME}" STREQUAL "iOS")
|
|
endif()
|
|
populate_tflite_source_vars("core" TFLITE_CORE_SRCS)
|
|
populate_tflite_source_vars("core/api" TFLITE_CORE_API_SRCS)
|
|
+populate_tflite_source_vars("core/c" TFLITE_CORE_C_SRCS)
|
|
populate_tflite_source_vars("c" TFLITE_C_SRCS)
|
|
populate_tflite_source_vars("delegates" TFLITE_DELEGATES_SRCS)
|
|
if(TFLITE_ENABLE_GPU)
|
|
@@ -483,6 +487,7 @@ endif()
|
|
# TFLite library
|
|
set(_ALL_TFLITE_SRCS
|
|
${TFLITE_CORE_API_SRCS}
|
|
+ ${TFLITE_CORE_C_SRCS}
|
|
${TFLITE_CORE_SRCS}
|
|
${TFLITE_C_SRCS}
|
|
${TFLITE_DELEGATES_FLEX_SRCS}
|
|
--
|
|
2.34.1
|
|
|