26 lines
875 B
Diff
26 lines
875 B
Diff
From c2260f7f28a092c715390a16f1176071dc030f7e Mon Sep 17 00:00:00 2001
|
|
From: j1nx <p.steenbergen@j1nx.nl>
|
|
Date: Thu, 14 May 2020 20:17:20 +0200
|
|
Subject: [PATCH 1/1] Only install typing requirement if Python version < 3.5
|
|
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 246a4e7..d4ab75f 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -26,7 +26,7 @@ setup(
|
|
version='0.3.15', # Also update in msk/__init__.py
|
|
packages=['msk', 'msk.actions'],
|
|
package_data={'msk': ['licenses/*']},
|
|
- install_requires=['GitPython>=3.0.5', 'typing', 'msm>=0.5.13', 'pygithub',
|
|
+ install_requires=['GitPython>=3.0.5', 'typing;python_version<"3.5"', 'msm>=0.5.13', 'pygithub',
|
|
'requests', 'colorama'],
|
|
url='https://github.com/MycroftAI/mycroft-skills-kit',
|
|
license='Apache-2.0',
|
|
--
|
|
2.20.1
|
|
|