mirror of
https://github.com/OpenVoiceOS/OpenVoiceOS
synced 2024-12-26 16:53:47 +01:00
48 lines
1.2 KiB
Diff
48 lines
1.2 KiB
Diff
From 6b6955e4ea7e0dd160a39f7a42fdf5cde78e0692 Mon Sep 17 00:00:00 2001
|
|
From: j1nx <p.steenbergen@j1nx.nl>
|
|
Date: Tue, 8 Mar 2022 21:03:56 +0100
|
|
Subject: [PATCH 1/1] No LF uninstall
|
|
|
|
---
|
|
setup.py | 13 -------------
|
|
1 file changed, 13 deletions(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index e8c5c76..2f6e142 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -1,22 +1,10 @@
|
|
import os
|
|
-from distutils.command.install import install
|
|
|
|
-import pip
|
|
from setuptools import setup
|
|
|
|
BASEDIR = os.path.abspath(os.path.dirname(__file__))
|
|
|
|
|
|
-class CustomInstall(install):
|
|
- """Custom handler for the 'install' command."""
|
|
-
|
|
- def run(self):
|
|
- # uninstall lingua_franca
|
|
- # the whole purpose of this package is to replace it
|
|
- pip.main(["uninstall", "lingua_franca", "-y"])
|
|
- super().run()
|
|
-
|
|
-
|
|
def package_files(directory):
|
|
paths = []
|
|
for (path, directories, filenames) in os.walk(directory):
|
|
@@ -68,7 +56,6 @@ setup(
|
|
name='ovos-lingua-franca',
|
|
version=get_version(),
|
|
packages=['lingua_franca', 'lingua_franca.lang'],
|
|
- cmdclass={'install': CustomInstall},
|
|
url='https://github.com/OpenVoiceOS/ovos-lingua-franca',
|
|
license='Apache2.0',
|
|
package_data={'': extra_files},
|
|
--
|
|
2.20.1
|
|
|