OpenVoiceOS/buildroot-external/package/python-lingua-franca/0001-Patch-setup.py-to-use-...

74 lines
2.2 KiB
Diff

From 4913ea0149f03cfccd62f1e41326164a457fdb38 Mon Sep 17 00:00:00 2001
From: Peter Steenbergen <info@j1nx.nl>
Date: Thu, 26 Mar 2020 08:41:14 +0100
Subject: [PATCH 1/1] Patch setup.py to use MANIFEST.in for package data
---
MANIFEST.in | 1 +
setup.py | 17 +----------------
2 files changed, 2 insertions(+), 16 deletions(-)
create mode 100644 MANIFEST.in
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..97513c5
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1 @@
+graft lingua_franca
diff --git a/setup.py b/setup.py
index ce0be2f..e25f0a2 100644
--- a/setup.py
+++ b/setup.py
@@ -3,14 +3,6 @@ import os
from setuptools import setup
-def package_files(directory):
- paths = []
- for (path, directories, filenames) in os.walk(directory):
- for filename in filenames:
- paths.append(os.path.join('..', path, filename))
- return paths
-
-
def required(requirements_file):
""" Read requirements file and remove comments and empty lines. """
with open(os.path.join(os.path.dirname(__file__), requirements_file),
@@ -20,25 +12,17 @@ def required(requirements_file):
if pkg.strip() and not pkg.startswith("#")]
-extra_files = package_files('lingua_franca')
-
-with open("readme.md", "r") as fh:
- long_description = fh.read()
-
setup(
name='lingua_franca',
version='0.2.0',
packages=['test', 'lingua_franca', 'lingua_franca.lang'],
url='https://github.com/MycroftAI/lingua-franca',
license='Apache2.0',
- package_data={'': extra_files},
include_package_data=True,
install_requires=required('requirements.txt'),
author='Mycroft AI',
author_email='dev@mycroft.ai',
description='Mycroft\'s multilingual text parsing and formatting library',
- long_description=long_description,
- long_description_content_type="text/markdown",
classifiers=[
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',
@@ -49,5 +33,6 @@ setup(
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
],
)
--
2.25.0