40 lines
1011 B
Diff
40 lines
1011 B
Diff
From 96cb99218e4f88ed2d7159b8b68ae6e163c0d9ac Mon Sep 17 00:00:00 2001
|
|
From: j1nx <p.steenbergen@j1nx.nl>
|
|
Date: Sun, 7 May 2023 14:22:38 +0200
|
|
Subject: [PATCH 1/1] Loosen requirements
|
|
|
|
---
|
|
pyproject.toml | 2 +-
|
|
setup.py | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/pyproject.toml b/pyproject.toml
|
|
index f86e9c4..23bbc17 100644
|
|
--- a/pyproject.toml
|
|
+++ b/pyproject.toml
|
|
@@ -19,7 +19,7 @@ homepage = "https://github.com/thebigmunch/tbm-utils"
|
|
[tool.poetry.dependencies]
|
|
python = "^3.6"
|
|
|
|
-attrs = ">=18.2,<19.4"
|
|
+attrs = ">=18.2"
|
|
pendulum = ">=2.0,<=3.0,!=2.0.5,!=2.1.0" # Work around https://github.com/sdispater/pendulum/issues/454
|
|
pprintpp = "0.*"
|
|
wrapt = "^1.0"
|
|
diff --git a/setup.py b/setup.py
|
|
index 9a1980e..16875cf 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -11,7 +11,7 @@ package_data = \
|
|
{'': ['*']}
|
|
|
|
install_requires = \
|
|
-['attrs>=18.2,<19.4',
|
|
+['attrs>=18.2',
|
|
'pendulum>=2.0,<=3.0,!=2.0.5,!=2.1.0',
|
|
'pprintpp<1.0.0',
|
|
'wrapt>=1.0,<2.0']
|
|
--
|
|
2.34.1
|
|
|