1
1
mirror of https://github.com/OpenVoiceOS/OpenVoiceOS synced 2024-12-12 00:55:31 +01:00
OpenVoiceOS/buildroot-patches/0012-Add-host-openssl-dependency-to-python3.patch
Peter Steenbergen 55846e484a MycroftOS: Implementation of a very first initial bootable version
- Add Buildroot patches to downgrade / upgrade package dependencies
  in line with the Mycroft A.I. software stack requirements.
- Add buildroot additional package dependencies in line with the
  Mycroft A.I. software stack requirements.
- Update rpi3 defconfig file.
- Implement initial root_fs overlay filestructure.
- Addition of some quick and dirty helper scripts.
- Update of README to reflect these changes.
2018-10-30 15:55:12 +01:00

36 lines
1.0 KiB
Diff

From 1d0657e62f0c754ba53f1ac49636cdc30e1ac133 Mon Sep 17 00:00:00 2001
From: Peter Steenbergen <info@j1nx.nl>
Date: Mon, 29 Oct 2018 16:18:13 +0100
Subject: [PATCH 1/1] Add host-openssl dependency to python3
---
package/python3/python3.mk | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/package/python3/python3.mk b/package/python3/python3.mk
index 6e61108661..e432e1da8f 100644
--- a/package/python3/python3.mk
+++ b/package/python3/python3.mk
@@ -33,8 +33,7 @@ HOST_PYTHON3_CONF_OPTS += \
--enable-unicodedata \
--disable-test-modules \
--disable-idle3 \
- --disable-ossaudiodev \
- --disable-openssl
+ --disable-ossaudiodev
# Make sure that LD_LIBRARY_PATH overrides -rpath.
# This is needed because libpython may be installed at the same time that
@@ -47,7 +46,7 @@ HOST_PYTHON3_CONF_ENV += \
PYTHON3_DEPENDENCIES = host-python3 libffi
-HOST_PYTHON3_DEPENDENCIES = host-expat host-zlib
+HOST_PYTHON3_DEPENDENCIES = host-expat host-zlib host-openssl
PYTHON3_INSTALL_STAGING = YES
--
2.11.0