OpenVoiceOS/buildroot-external/package/python-adapt-parser/0001-Simplify-setup.patch

51 lines
1.5 KiB
Diff

From 80e6b553e2e5343e5b8064bfe8af86264e3227d4 Mon Sep 17 00:00:00 2001
From: j1nx <p.steenbergen@j1nx.nl>
Date: Sun, 7 May 2023 13:28:28 +0200
Subject: [PATCH 1/1] Simplify setup
---
setup.py | 16 ----------------
1 file changed, 16 deletions(-)
diff --git a/setup.py b/setup.py
index 9f7b685..d642737 100644
--- a/setup.py
+++ b/setup.py
@@ -18,26 +18,12 @@ __author__ = 'seanfitz'
import os
from setuptools import setup
-with open("README.md", "r") as fh:
- long_description = fh.read()
-
-
-def required(requirements_file):
- """Read requirements file and remove comments and empty lines."""
- base_dir = os.path.abspath(os.path.dirname(__file__))
- with open(os.path.join(base_dir, requirements_file), 'r') as f:
- requirements = f.read().splitlines()
- return [pkg for pkg in requirements
- if pkg.strip() and not pkg.startswith("#")]
-
setup(
name="adapt-parser",
version="1.0.0",
author="Sean Fitzgerald",
author_email="sean@fitzgeralds.me",
description=("A text-to-intent parsing framework."),
- long_description=long_description,
- long_description_content_type="text/markdown",
license=("Apache License 2.0"),
keywords="natural language processing",
url="https://github.com/MycroftAI/adapt",
@@ -55,6 +41,4 @@ setup(
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
],
-
- install_requires=required('requirements.txt')
)
--
2.34.1